.ui Files are listed under the _autogen target in Visual Studio instead of the target to which they belong. Is this a bug or feature?

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

.ui Files are listed under the _autogen target in Visual Studio instead of the target to which they belong. Is this a bug or feature?

Ulrich Hierl-2
Hello cmake community,

I have a project that uses Qt 5.9.1 and cmake 3.12.4 and Visual Studio
2017. I have targets for which I use

set(CMAKE_AUTOMOC ON)

I do not use CMAKE_AUTOUIC or CMAKE_AUTORC

Switching the CMAKE_AUTOMOC option on causes the <target>_autogen
targets to be created. My problem is that in the Visual Studio solution
explorer the .ui files are listed in the _autogen target and not in the
target to which they belong. Can you reproduce this behavior? I this how
it should be?

Thank you for your time!

Knitschi

--

Powered by www.kitware.com

Please keep messages on-topic and check the CMake FAQ at: http://www.cmake.org/Wiki/CMake_FAQ

Kitware offers various services to support the CMake community. For more information on each offering, please visit:

CMake Support: http://cmake.org/cmake/help/support.html
CMake Consulting: http://cmake.org/cmake/help/consulting.html
CMake Training Courses: http://cmake.org/cmake/help/training.html

Visit other Kitware open-source projects at http://www.kitware.com/opensource/opensource.html

Follow this link to subscribe/unsubscribe:
https://cmake.org/mailman/listinfo/cmake