openmp test with CMAKE_EXECUTABLE_SUFFIX changed

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

openmp test with CMAKE_EXECUTABLE_SUFFIX changed

Georg Schramm
Dear all,
 
I am running cmake 3.8 under windows 7 (for VS 2017).
When I use find_package(OpenMP) after I set CMAKE_EXECUTABLE_SUFFIX,
the openmp test fails.
 
Here is a minimal example:
----------------------------------------------
cmake_minimum_required(VERSION 3.1.0)
set (CMAKE_BUILD_TYPE Release)
project(test)
set (CMAKE_EXECUTABLE_SUFFIX "_foo")
find_package(OpenMP)
if (OPENMP_FOUND)
  set (CMAKE_C_FLAGS "${CMAKE_C_FLAGS} ${OpenMP_C_FLAGS}")
endif()
----------------------------------------------
 
I think the binary that is generated is other than expected.
If I do not change CMAKE_EXECUTABLE_SUFFIX everything
works fine.
 
Is that behaviour intended?
 
Bests,
Georg
 

--

Powered by www.kitware.com

Please keep messages on-topic and check the CMake FAQ at: http://www.cmake.org/Wiki/CMake_FAQ

Kitware offers various services to support the CMake community. For more information on each offering, please visit:

CMake Support: http://cmake.org/cmake/help/support.html
CMake Consulting: http://cmake.org/cmake/help/consulting.html
CMake Training Courses: http://cmake.org/cmake/help/training.html

Visit other Kitware open-source projects at http://www.kitware.com/opensource/opensource.html

Follow this link to subscribe/unsubscribe:
http://public.kitware.com/mailman/listinfo/cmake
Loading...