Troubles with ExternalProject_Add.

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

Troubles with ExternalProject_Add.

Steven Truppe

Hi everyone,

I've troubles with ExternalProject_Add:

when i do build the library  manualy (clone the repo and build it with mkdir build;cd build; cmake -DCMAKE_BUILD_TYPE:String=Release -DGLAD_INSTALL=ON -DCMAKE_INSTALL_PREFIX=/home/stuv/glad_examples) it does work and i've the installation at /home/stuv/glad_examples.


But the external project add seems to miss an argument because he doesn't install anything.

Here the code of ExternalProject_Add:

ExternalProject_Add(external_glad
        PREFIX ${CMAKE_BINARY_DIR}/glad
        GIT_REPOSITORY ${GLAD_REPO}
        GIT_TAG ${GLAD_TAG}
        GIT_PROGRESS true
        GIT_SHALLOW True
        SOURCE_DIR ${CMAKE_BINARY_DIR}/glad-src
        INSTALL_DIR ${CMAKE_BINARY_DIR}/glad-download
        CMAKE_ARGS -DCMAKE_BUILD_TYPE:String=${CMAKE_BUILD_TYPE} -DGLAD_INSTALL=ON -DCMAKE_INSTALL_PREFIX=${OUTPUT_PATH}/glad
)

I hope someone here does see my problem.


best regards!


--

Powered by www.kitware.com

Please keep messages on-topic and check the CMake FAQ at: http://www.cmake.org/Wiki/CMake_FAQ

Kitware offers various services to support the CMake community. For more information on each offering, please visit:

CMake Support: http://cmake.org/cmake/help/support.html
CMake Consulting: http://cmake.org/cmake/help/consulting.html
CMake Training Courses: http://cmake.org/cmake/help/training.html

Visit other Kitware open-source projects at http://www.kitware.com/opensource/opensource.html

Follow this link to subscribe/unsubscribe:
https://cmake.org/mailman/listinfo/cmake
Reply | Threaded
Open this post in threaded view
|

Re: Troubles with ExternalProject_Add.

Steven Truppe

Found the error, thank you anyway  -  you guys are allways a good way to get help about cmake, i'm starting to understand cmake slowly but it's getting easier and easier, cmake is a great build system.


best regards!

On 08.06.19 14:47, Steven Truppe wrote:

Hi everyone,

I've troubles with ExternalProject_Add:

when i do build the library  manualy (clone the repo and build it with mkdir build;cd build; cmake -DCMAKE_BUILD_TYPE:String=Release -DGLAD_INSTALL=ON -DCMAKE_INSTALL_PREFIX=/home/stuv/glad_examples) it does work and i've the installation at /home/stuv/glad_examples.


But the external project add seems to miss an argument because he doesn't install anything.

Here the code of ExternalProject_Add:

ExternalProject_Add(external_glad
        PREFIX ${CMAKE_BINARY_DIR}/glad
        GIT_REPOSITORY ${GLAD_REPO}
        GIT_TAG ${GLAD_TAG}
        GIT_PROGRESS true
        GIT_SHALLOW True
        SOURCE_DIR ${CMAKE_BINARY_DIR}/glad-src
        INSTALL_DIR ${CMAKE_BINARY_DIR}/glad-download
        CMAKE_ARGS -DCMAKE_BUILD_TYPE:String=${CMAKE_BUILD_TYPE} -DGLAD_INSTALL=ON -DCMAKE_INSTALL_PREFIX=${OUTPUT_PATH}/glad
)

I hope someone here does see my problem.


best regards!



--

Powered by www.kitware.com

Please keep messages on-topic and check the CMake FAQ at: http://www.cmake.org/Wiki/CMake_FAQ

Kitware offers various services to support the CMake community. For more information on each offering, please visit:

CMake Support: http://cmake.org/cmake/help/support.html
CMake Consulting: http://cmake.org/cmake/help/consulting.html
CMake Training Courses: http://cmake.org/cmake/help/training.html

Visit other Kitware open-source projects at http://www.kitware.com/opensource/opensource.html

Follow this link to subscribe/unsubscribe:
https://cmake.org/mailman/listinfo/cmake