Problem with Ninja on Windows

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

Problem with Ninja on Windows

Robert Bielik-4
Hi all,

I've come to a problem with Ninja on Windows, but only when building for MSVC amd64 toolchain. With x86, it works OK. The error I get is:

CMake Error: Error required internal CMake variable not set, cmake may be not be built correctly.
Missing variable is:
CMAKE_ASM_NASM_COMPILE_OBJECT

It is boringssl (from the gRPC project) that needs NASM. But I find it odd that the x86 generator works, but not the amd64 one ?

Any ideas what I should look for ?

Regards
/Robert

--

Powered by www.kitware.com

Please keep messages on-topic and check the CMake FAQ at: http://www.cmake.org/Wiki/CMake_FAQ

Kitware offers various services to support the CMake community. For more information on each offering, please visit:

CMake Support: http://cmake.org/cmake/help/support.html
CMake Consulting: http://cmake.org/cmake/help/consulting.html
CMake Training Courses: http://cmake.org/cmake/help/training.html

Visit other Kitware open-source projects at http://www.kitware.com/opensource/opensource.html

Follow this link to subscribe/unsubscribe:
http://public.kitware.com/mailman/listinfo/cmake
Reply | Threaded
Open this post in threaded view
|

Re: Problem with Ninja on Windows

Robert Bielik-4
I've found the culprit, in boringssl/crypto CMakeLists.txt there is:

enable_language(ASM_NASM)

If I remove this (since I don't use asm), it works on both x86 and amd64 (!)

> -----Original Message-----
> From: CMake [mailto:[hidden email]] On Behalf Of Robert
> Bielik
> Sent: den 24 april 2017 13:28
> To: [hidden email]
> Subject: [CMake] Problem with Ninja on Windows
>
> Hi all,
>
> I've come to a problem with Ninja on Windows, but only when building for
> MSVC amd64 toolchain. With x86, it works OK. The error I get is:
>
> CMake Error: Error required internal CMake variable not set, cmake may be
> not be built correctly.
> Missing variable is:
> CMAKE_ASM_NASM_COMPILE_OBJECT
>
> It is boringssl (from the gRPC project) that needs NASM. But I find it odd that
> the x86 generator works, but not the amd64 one ?
>
> Any ideas what I should look for ?
>
> Regards
> /Robert
>
> --
>
> Powered by www.kitware.com
>
> Please keep messages on-topic and check the CMake FAQ at:
> http://www.cmake.org/Wiki/CMake_FAQ
>
> Kitware offers various services to support the CMake community. For more
> information on each offering, please visit:
>
> CMake Support: http://cmake.org/cmake/help/support.html
> CMake Consulting: http://cmake.org/cmake/help/consulting.html
> CMake Training Courses: http://cmake.org/cmake/help/training.html
>
> Visit other Kitware open-source projects at
> http://www.kitware.com/opensource/opensource.html
>
> Follow this link to subscribe/unsubscribe:
> http://public.kitware.com/mailman/listinfo/cmake
--

Powered by www.kitware.com

Please keep messages on-topic and check the CMake FAQ at: http://www.cmake.org/Wiki/CMake_FAQ

Kitware offers various services to support the CMake community. For more information on each offering, please visit:

CMake Support: http://cmake.org/cmake/help/support.html
CMake Consulting: http://cmake.org/cmake/help/consulting.html
CMake Training Courses: http://cmake.org/cmake/help/training.html

Visit other Kitware open-source projects at http://www.kitware.com/opensource/opensource.html

Follow this link to subscribe/unsubscribe:
http://public.kitware.com/mailman/listinfo/cmake