Install cmake 3.10.1 failed

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

Install cmake 3.10.1 failed

Masaru Tsuchiyama
Hi,

I tried to install cmake 3.10.1 (cmake-3.10.1-Darwin-x86_64.dmg) to Mac OS X High Sierra. But it failed with the attached error.

cmake 3.9.4 has been already installed on the machine.


The error message says some necessary items were not found, the operation couldn't be completed (the error code is -43).

What should I do to fix it?

Regards.
Masaru.


--

Powered by www.kitware.com

Please keep messages on-topic and check the CMake FAQ at: http://www.cmake.org/Wiki/CMake_FAQ

Kitware offers various services to support the CMake community. For more information on each offering, please visit:

CMake Support: http://cmake.org/cmake/help/support.html
CMake Consulting: http://cmake.org/cmake/help/consulting.html
CMake Training Courses: http://cmake.org/cmake/help/training.html

Visit other Kitware open-source projects at http://www.kitware.com/opensource/opensource.html

Follow this link to subscribe/unsubscribe:
https://cmake.org/mailman/listinfo/cmake

screenshot1.png (101K) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Re: Install cmake 3.10.1 failed

Carlton banks
redirected..

Den 30. dec. 2017 kl. 12.09 skrev masaru tsuchiyama <[hidden email]>:

Hi,

Thank you for the reply.
I installed from the GUI installer.

I could find the reason and fix the problem.
There was a file system error and the error had nothing to do with cmake installer.

I booted my Mac with the safe mode by pressing command + R key.
By booting the safe mode, Mac boot disk error seems to be fixed automatically.

Regards.
Masaru.



2017-12-30 19:13 GMT+09:00 Noflanco <[hidden email]>:
Have you tried to install from the terminal....   btw. What does it say when you type cmake -v in the terminal?

> Den 30. dec. 2017 kl. 10.56 skrev masaru tsuchiyama <[hidden email]>:
>
> Hi,
>
> I tried to install cmake 3.10.1 (cmake-3.10.1-Darwin-x86_64.dmg) to Mac OS X High Sierra. But it failed with the attached error.
>
> cmake 3.9.4 has been already installed on the machine.
>
>
> The error message says some necessary items were not found, the operation couldn't be completed (the error code is -43).
>
> What should I do to fix it?
>
> Regards.
> Masaru.
>
> <screenshot1.png>
> --
>
> Powered by www.kitware.com
>
> Please keep messages on-topic and check the CMake FAQ at: http://www.cmake.org/Wiki/CMake_FAQ
>
> Kitware offers various services to support the CMake community. For more information on each offering, please visit:
>
> CMake Support: http://cmake.org/cmake/help/support.html
> CMake Consulting: http://cmake.org/cmake/help/consulting.html
> CMake Training Courses: http://cmake.org/cmake/help/training.html
>
> Visit other Kitware open-source projects at http://www.kitware.com/opensource/opensource.html
>
> Follow this link to subscribe/unsubscribe:
> https://cmake.org/mailman/listinfo/cmake



--

Powered by www.kitware.com

Please keep messages on-topic and check the CMake FAQ at: http://www.cmake.org/Wiki/CMake_FAQ

Kitware offers various services to support the CMake community. For more information on each offering, please visit:

CMake Support: http://cmake.org/cmake/help/support.html
CMake Consulting: http://cmake.org/cmake/help/consulting.html
CMake Training Courses: http://cmake.org/cmake/help/training.html

Visit other Kitware open-source projects at http://www.kitware.com/opensource/opensource.html

Follow this link to subscribe/unsubscribe:
https://cmake.org/mailman/listinfo/cmake