Imported targets not available for Boost version

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Imported targets not available for Boost version

Burlen Loring
I have the above error after having to upgrade CMake on my Mac. I have
read posts on SO and this list about this issue, stating that it is
caused by Boost release being newer than Cmake. However it seems that it
is also can be caused by Boost release being older than CMake since this
version of Boost worked before I upgraded Cmake.

Is any guidance about which versions of CMake work with which versions
of Boost?

CMake Warning at
/usr/local/Cellar/cmake/3.8.2/share/cmake/Modules/FindBoost.cmake:765
(message):
   Imported targets not available for Boost version
Call Stack (most recent call first):
/usr/local/Cellar/cmake/3.8.2/share/cmake/Modules/FindBoost.cmake:869
(_Boost_COMPONENT_DEPENDENCIES)
/usr/local/Cellar/cmake/3.8.2/share/cmake/Modules/FindBoost.cmake:1472
(_Boost_MISSING_DEPENDENCIES)
   CMakeLists.txt:142 (find_package)


-- Boost fetaures -- not found. set BOOST_ROOT to enable.
CMake Warning at CMakeLists.txt:148 (message):
   Boost is required for command line applications
--

Powered by www.kitware.com

Please keep messages on-topic and check the CMake FAQ at: http://www.cmake.org/Wiki/CMake_FAQ

Kitware offers various services to support the CMake community. For more information on each offering, please visit:

CMake Support: http://cmake.org/cmake/help/support.html
CMake Consulting: http://cmake.org/cmake/help/consulting.html
CMake Training Courses: http://cmake.org/cmake/help/training.html

Visit other Kitware open-source projects at http://www.kitware.com/opensource/opensource.html

Follow this link to subscribe/unsubscribe:
http://public.kitware.com/mailman/listinfo/cmake
Loading...