Got Weird Error When Trying to Configure LLVM Version 10

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

Got Weird Error When Trying to Configure LLVM Version 10

Osman Zakir
I want to build LLVM 10 so that I can see if having the same version of LLVM installed that my EMSDK version is using will help.  I want to do this so I can build the Qt Documentation as well when I build Qt for WebAssembly.  Building the Documentation requires LLVM and I want to avoid conflicts caused by having different versions of LLVM.  

Anyway, the command I ran was: 
"cmake -DCMAKE_INSTALL_PREFIX=../install -G"Visual Studio 16 2019" -Thost=x64 -A x86 -DLLVM_ENABLE_PROJECTS="clang;clang-tools-extra;lld;lldb;libcxx;libcxxabi" -DCMAKE_BUILD-TYPE=Release -MSVC_RUNTIME_TYPE=/MT -DLLVM_TARGETS_TO_BUILD=all -DLLVM_ENABLE_THREADS=On -DLLVM_CXX_STD="c++17" -DLLVM_ENABLE_PEDANTIC=On -DCMAKE_CXX_FLAGS="/std:c++17;/permissive-;/MT;/EHsc" ../llvm"

I put the error message I got in the .log file I'm attaching to this message.  Any help is appreciated.  Thanks.

--

Powered by www.kitware.com

Please keep messages on-topic and check the CMake FAQ at: http://www.cmake.org/Wiki/CMake_FAQ

Kitware offers various services to support the CMake community. For more information on each offering, please visit:

CMake Support: http://cmake.org/cmake/help/support.html
CMake Consulting: http://cmake.org/cmake/help/consulting.html
CMake Training Courses: http://cmake.org/cmake/help/training.html

Visit other Kitware open-source projects at http://www.kitware.com/opensource/opensource.html

Follow this link to subscribe/unsubscribe:
https://cmake.org/mailman/listinfo/cmake

cmake_config.log (2K) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Re: Got Weird Error When Trying to Configure LLVM Version 10

Eric Doenges

MSBuild is complaining that the generated project file doesn't contain a 32 bit debug target - which is no surprise, because you told CMake to generate a project for a release build. You will probably need to tell msbuild.exe that you want to build a release build with the "/p:Configuration=Release" command line option.


Am 26.10.19 um 18:38 schrieb Osman Zakir:

I want to build LLVM 10 so that I can see if having the same version of LLVM installed that my EMSDK version is using will help.  I want to do this so I can build the Qt Documentation as well when I build Qt for WebAssembly.  Building the Documentation requires LLVM and I want to avoid conflicts caused by having different versions of LLVM.  

Anyway, the command I ran was: 
"cmake -DCMAKE_INSTALL_PREFIX=../install -G"Visual Studio 16 2019" -Thost=x64 -A x86 -DLLVM_ENABLE_PROJECTS="clang;clang-tools-extra;lld;lldb;libcxx;libcxxabi" -DCMAKE_BUILD-TYPE=Release -MSVC_RUNTIME_TYPE=/MT -DLLVM_TARGETS_TO_BUILD=all -DLLVM_ENABLE_THREADS=On -DLLVM_CXX_STD="c++17" -DLLVM_ENABLE_PEDANTIC=On -DCMAKE_CXX_FLAGS="/std:c++17;/permissive-;/MT;/EHsc" ../llvm"

I put the error message I got in the .log file I'm attaching to this message.  Any help is appreciated.  Thanks.

--

Dr. Eric Dönges
Senior Software Engineer

MVTec Software GmbH | Arnulfstr. 205 | 80634 Munich | Germany
[hidden email] | Tel: +49 89 457 695-0 | www.mvtec.com

Find our privacy policy here.

 Sign up for our MVTec Newsletter!

Geschäftsführer: Dr. Wolfgang Eckstein, Dr. Olaf Munkelt
Amtsgericht München HRB 114695

 

MVTec Software GmbH Logo

--

Powered by www.kitware.com

Please keep messages on-topic and check the CMake FAQ at: http://www.cmake.org/Wiki/CMake_FAQ

Kitware offers various services to support the CMake community. For more information on each offering, please visit:

CMake Support: http://cmake.org/cmake/help/support.html
CMake Consulting: http://cmake.org/cmake/help/consulting.html
CMake Training Courses: http://cmake.org/cmake/help/training.html

Visit other Kitware open-source projects at http://www.kitware.com/opensource/opensource.html

Follow this link to subscribe/unsubscribe:
https://cmake.org/mailman/listinfo/cmake