Eclipse tries to build x64 instead of x86

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

Eclipse tries to build x64 instead of x86

Dixon, Shane
I'm trying the Eclipse generator for the first time since loading 2.8.  When I generate using "NMake Makefiles", I can run "nmake" and everything builds correctly using x86.  When I use generator "Eclipse CDT4 - NMake Makefiles", I get an environment I can successfully import into eclipse.  When I try to build, I get this error:

 : fatal error LNK1112: module machine type 'X86' conflicts with target machine type 'x64'

I'm not sure where it's picking up this /machine:x64 argument in the build.  Did the generator mis-detect my machine type?

--
Shane Dixon
Linux Engineer
Atmel Corporation

_______________________________________________
Powered by www.kitware.com

Visit other Kitware open-source projects at http://www.kitware.com/opensource/opensource.html

Please keep messages on-topic and check the CMake FAQ at: http://www.cmake.org/Wiki/CMake_FAQ

Follow this link to subscribe/unsubscribe:
http://www.cmake.org/mailman/listinfo/cmake
Reply | Threaded
Open this post in threaded view
|

Re: Eclipse tries to build x64 instead of x86

Dixon, Shane
 
Ok, nevermind, I built again using "-DCMAKE_BUILD_TYPE=Release" and that worked.  I wiped the build directory entirely and did "-DCMAKE_BUILD_TYPE=Release" and it's working again.  Strange.  Maybe some files just got screwed up somehow.  That seems to have fixed it so please disregard my previous question.


--
Shane Dixon
Linux Engineer
Atmel Corporation


-----Original Message-----
From: [hidden email] [mailto:[hidden email]] On Behalf Of Dixon, Shane
Sent: Friday, December 11, 2009 1:40 PM
To: [hidden email]
Subject: [CMake] Eclipse tries to build x64 instead of x86

I'm trying the Eclipse generator for the first time since loading 2.8.  When I generate using "NMake Makefiles", I can run "nmake" and everything builds correctly using x86.  When I use generator "Eclipse CDT4 - NMake Makefiles", I get an environment I can successfully import into eclipse.  When I try to build, I get this error:

 : fatal error LNK1112: module machine type 'X86' conflicts with target machine type 'x64'

I'm not sure where it's picking up this /machine:x64 argument in the build.  Did the generator mis-detect my machine type?

--
Shane Dixon
Linux Engineer
Atmel Corporation

_______________________________________________
Powered by www.kitware.com

Visit other Kitware open-source projects at http://www.kitware.com/opensource/opensource.html

Please keep messages on-topic and check the CMake FAQ at: http://www.cmake.org/Wiki/CMake_FAQ

Follow this link to subscribe/unsubscribe:
http://www.cmake.org/mailman/listinfo/cmake
_______________________________________________
Powered by www.kitware.com

Visit other Kitware open-source projects at http://www.kitware.com/opensource/opensource.html

Please keep messages on-topic and check the CMake FAQ at: http://www.cmake.org/Wiki/CMake_FAQ

Follow this link to subscribe/unsubscribe:
http://www.cmake.org/mailman/listinfo/cmake
Reply | Threaded
Open this post in threaded view
|

Re: Eclipse tries to build x64 instead of x86

John Drescher-2
> Ok, nevermind, I built again using "-DCMAKE_BUILD_TYPE=Release" and that worked.  I wiped the build directory entirely and did "-DCMAKE_BUILD_TYPE=Release" and it's working again.  Strange.  Maybe some files just got screwed up somehow.  That seems to have fixed it so please disregard my previous question.
>

I have seen this once on a Visual Studio 2005 C++ project with CMake
2.8.0 and wiping the cache and regenerating the config also fixed the
issue.

John
_______________________________________________
Powered by www.kitware.com

Visit other Kitware open-source projects at http://www.kitware.com/opensource/opensource.html

Please keep messages on-topic and check the CMake FAQ at: http://www.cmake.org/Wiki/CMake_FAQ

Follow this link to subscribe/unsubscribe:
http://www.cmake.org/mailman/listinfo/cmake