Eclipse CDT 5.x and cmake 2.6.x

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

Eclipse CDT 5.x and cmake 2.6.x

dim-3
Hi group!

I'm using cmake 2.6.x. I understand that it supports Eclipse CDT 4.x. Does it implicitly supports CDT 5.x or CDT 6.x?

Thanks
Dima

_______________________________________________
Powered by www.kitware.com

Visit other Kitware open-source projects at http://www.kitware.com/opensource/opensource.html

Please keep messages on-topic and check the CMake FAQ at: http://www.cmake.org/Wiki/CMake_FAQ

Follow this link to subscribe/unsubscribe:
http://www.cmake.org/mailman/listinfo/cmake
Reply | Threaded
Open this post in threaded view
|

Re: Eclipse CDT 5.x and cmake 2.6.x

Will Dicharry
Dim wrote:
> Hi group!
>
> I'm using cmake 2.6.x. I understand that it supports Eclipse CDT 4.x.
> Does it implicitly supports CDT 5.x or CDT 6.x?

I don't think the support is official, but I am currently using CMake
2.6.4 with Eclipse Galileo and CDT 6 with no problems.

--Will

>
> Thanks
> Dima
>
>
> ------------------------------------------------------------------------
>
> _______________________________________________
> Powered by www.kitware.com
>
> Visit other Kitware open-source projects at http://www.kitware.com/opensource/opensource.html
>
> Please keep messages on-topic and check the CMake FAQ at: http://www.cmake.org/Wiki/CMake_FAQ
>
> Follow this link to subscribe/unsubscribe:
> http://www.cmake.org/mailman/listinfo/cmake


--
Will Dicharry
Software Developer
Stellar Science Ltd Co
_______________________________________________
Powered by www.kitware.com

Visit other Kitware open-source projects at http://www.kitware.com/opensource/opensource.html

Please keep messages on-topic and check the CMake FAQ at: http://www.cmake.org/Wiki/CMake_FAQ

Follow this link to subscribe/unsubscribe:
http://www.cmake.org/mailman/listinfo/cmake
Reply | Threaded
Open this post in threaded view
|

Re: Eclipse CDT 5.x and cmake 2.6.x

Miguel A. Figueroa-Villanueva
In reply to this post by dim-3
On Mon, Aug 3, 2009 at 2:30 AM, Dim wrote:
> Hi group!
>
> I'm using cmake 2.6.x. I understand that it supports Eclipse CDT 4.x. Does
> it implicitly supports CDT 5.x or CDT 6.x?
>
> Thanks
> Dima

When I worked in the CDT generator I wasn't (and still am not)
familiar with the release cycle or the design constraints of the CDT,
hence the name includes CDT4 thinking it might not be compatible with
the future versions. However, as another user points out people have
successfully used it with CDT 5/6.

So, as long as the CDT doesn't break the xml format for external
makefiles you should be able to use it.

--Miguel
_______________________________________________
Powered by www.kitware.com

Visit other Kitware open-source projects at http://www.kitware.com/opensource/opensource.html

Please keep messages on-topic and check the CMake FAQ at: http://www.cmake.org/Wiki/CMake_FAQ

Follow this link to subscribe/unsubscribe:
http://www.cmake.org/mailman/listinfo/cmake