Ctest logs error but returns zero exit code.

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Ctest logs error but returns zero exit code.

Mike Nicholson

Hello,

 

I recently ran into a situation where one of our scripts was attempting to run CTest in the wrong directory.   CTest did output a helpful error message:

 

    *********************************

    No test configuration file found!

    *********************************

    Usage

   

      ctest [options]

   

But it still returned an exit code of zero.  This behavior seems to be counterintuitive. CTest checks for the error condition (no arguments are specified at command line and the default CMake or Dart TestFile doesn’t exist) and logs the error but does not update the exit code accordingly.

 

I’d be happy to contribute a patch but before investing the time to do so I’d like to understand if this is expected behavior and if so the reasoning behind it.

 

Thanks,

Mike Nicholson

 


--

Powered by www.kitware.com

Please keep messages on-topic and check the CMake FAQ at: http://www.cmake.org/Wiki/CMake_FAQ

Kitware offers various services to support the CMake community. For more information on each offering, please visit:

CMake Support: http://cmake.org/cmake/help/support.html
CMake Consulting: http://cmake.org/cmake/help/consulting.html
CMake Training Courses: http://cmake.org/cmake/help/training.html

Visit other Kitware open-source projects at http://www.kitware.com/opensource/opensource.html

Follow this link to subscribe/unsubscribe:
http://public.kitware.com/mailman/listinfo/cmake
Loading...