CTest failed to find the correct drop site

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

CTest failed to find the correct drop site

romain.jacquet.dev
Hi everybody,

   I'm currently having a problem using cmake and ctest. I have a project with
test. The basic work cycle (cmake && make && make install && make test) is fine.
But when I run ctest -D Experimental the test is launch but the files are
submitting to the wrong dashboard (public.kitware.com instead of my own cdash).

   In my top-level CMakeLists.txt I have include the CTestConfig.cmake generated
by the CDash site.

   [...]
   include(CTestConfig)
   [...]

The generated CTestConfig is:
[...]
ENABLE_TESTING()
INCLUDE(CTest)
set(CTEST_PROJECT_NAME "Qb_test_compile")
set(CTEST_NIGHTLY_START_TIME "00:00:00 EST")

set(CTEST_DROP_METHOD "http")
set(CTEST_DROP_SITE "172.21.101.61")
set(CTEST_DROP_LOCATION "/cdash/submit.php?project=Qb_test_compile")
set(CTEST_DROP_SITE_CDASH TRUE)

At the end of my top-level CMakeLists.txt, the CTEST_DROP_SITE has the correct
value. But the DartConfigurationFile.tcl seems not to be correct:
$ grep -i dropsite DartConfiguration.tcl
DropSite: public.kitware.com
DropSiteUser:
DropSitePassword:
DropSiteMode:

And ctest submit to the wrong dashboard:
  Site: VE3878
   Build name: Linux-c++
Create new tag: 20091002-1636 - Experimental
Start processing tests
Configure project
   Each . represents 1024 bytes of output
    . Size of output: 0K
Error(s) when updating the project
Build project
   Each symbol represents 1024 bytes of output.
   '!' represents an error and '*' a warning.
    . Size of output: 0K
   1 Compiler errors
   0 Compiler warnings
Test project /home/rjacquet/work/qbee/Development/tmp
  1/  1 Testing TestProject                      Passed

100% tests passed, 0 tests failed out of 1
Performing coverage
 Cannot find any coverage files. Ignoring Coverage request.
   Use HTTP Proxy: http://lucluc:XXXXX5@192.168.162.142:8080
Submit files (using http)
   Using HTTP submit method
   Drop site: http://public.kitware.com/cgi-bin/HTTPUploadDartFile.cgi
   Uploaded:
/home/rjacquet/work/qbee/Development/tmp/Testing/20091002-1636/Build.xml
   Uploaded:
/home/rjacquet/work/qbee/Development/tmp/Testing/20091002-1636/Configure.xml
   Uploaded:
/home/rjacquet/work/qbee/Development/tmp/Testing/20091002-1636/Test.xml
   Using HTTP trigger method
   Trigger site:
http://public.kitware.com/cgi-bin/Submit-Random-TestingResults.cgi
   Dart server triggered...
   Submission successful
Errors while running CTest



Thanks in advance for any help.
_______________________________________________
Powered by www.kitware.com

Visit other Kitware open-source projects at http://www.kitware.com/opensource/opensource.html

Please keep messages on-topic and check the CMake FAQ at: http://www.cmake.org/Wiki/CMake_FAQ

Follow this link to subscribe/unsubscribe:
http://www.cmake.org/mailman/listinfo/cmake