CMake 3.10 adding mystery source file to target?

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

CMake 3.10 adding mystery source file to target?

Michael Jackson
I just tried to configure our project with CMake 3.10 and got some errors. The same project configures fine with CMake 3.8.x and 3.9.x as evidenced here (http://my.cdash.org/index.php?project=DREAM3D).

I get an error about a Qt5 qrc generated file not being found.

-- Configuring done
CMake Error in /Users/mjackson/Workspace/DREAM3D_Plugins/AskNDEToolbox/Applications/ScanViewer/CMakeLists.txt:
  Cannot find source file:

    /Users/mjackson/Workspace/DREAM3D-Build/3.10/Plugins/AskNDEToolbox/qrc_AskNDEToolbox.cpp

  Tried extensions .c .C .c++ .cc .cpp .cxx .m .M .mm .h .hh .h++ .hm .hpp
  .hxx .in .txx


-- Generating done
-- Build files have been written to: /Users/mjackson/Workspace/DREAM3D-Build/3.10


But the issue is that if I actually print out all the source files for the " ScanViewer " taget, "qrc_AskNDEToolbox.cpp" NEVER shows up? There is another target that uses that file but NOT ScanViewer.

I am also getting some errors on the same project but on Windows (the previous was on macOS Sierra) where some of our plugins that get configured all of a sudden cannot find some of their files. I have not tried on Linux x64 yet to figure out if anything is broken on that side.

Thanks for any information anyone may have. Thoughts. Ideas. All are welcome.

--
Michael Jackson | Owner, President
      BlueQuartz Software
[e] [hidden email]
[w] www.bluequartz.net


--

Powered by www.kitware.com

Please keep messages on-topic and check the CMake FAQ at: http://www.cmake.org/Wiki/CMake_FAQ

Kitware offers various services to support the CMake community. For more information on each offering, please visit:

CMake Support: http://cmake.org/cmake/help/support.html
CMake Consulting: http://cmake.org/cmake/help/consulting.html
CMake Training Courses: http://cmake.org/cmake/help/training.html

Visit other Kitware open-source projects at http://www.kitware.com/opensource/opensource.html

Follow this link to subscribe/unsubscribe:
http://public.kitware.com/mailman/listinfo/cmake