Building using Qt 5.8 and VS2017.

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Building using Qt 5.8 and VS2017.

Andrew Maclean-3
At present the builds will fail.

I have posted a report on the Qt forum:

In the interim here is a temporary fix:

The problem relates to the Qt macro: 
**Q_DECL_CONSTEXPR**

If it is commented out in lines  593 to 714 of *qalgorithms.h* then the builds work for CMake and VTK and any other Qt build using VS2017.

Regards
   Andrew
--
___________________________________________
Andrew J. P. Maclean

___________________________________________

--

Powered by www.kitware.com

Please keep messages on-topic and check the CMake FAQ at: http://www.cmake.org/Wiki/CMake_FAQ

Kitware offers various services to support the CMake community. For more information on each offering, please visit:

CMake Support: http://cmake.org/cmake/help/support.html
CMake Consulting: http://cmake.org/cmake/help/consulting.html
CMake Training Courses: http://cmake.org/cmake/help/training.html

Visit other Kitware open-source projects at http://www.kitware.com/opensource/opensource.html

Follow this link to subscribe/unsubscribe:
http://public.kitware.com/mailman/listinfo/cmake
Loading...